Unable to Save Drivers on Allocation Page Error
Incident Report for FreightTracker
Resolved
This incident has been resolved.
Posted May 12, 2023 - 08:40 AEST
Investigating
We are currently investigating this issue
Posted May 12, 2023 - 07:44 AEST
This incident affected: Containers Module (Allocation Screen, Booking Screen, Vessels Screen, Vessels Update, Jobs Screen, Planning Screen).